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Module 1. Introduction to MS Project Professional 

Contents 

• Introduction to MS Project 

• Operation on a project  

• Tasks and their properties 

• Defining dependencies between tasks 

• Constraints 

Introduction 

Microsoft Project Professional is software designed especially for project 

managers and all project group members who are somehow involved in process 

of project management or control. It provides set of ergonomic tools that support 

user in all activities at any stage of the project lifecycle: 

1. Project designing 

a. Creating list of tasks and their dependencies 

b. Defining pool of resources 

c. Calculating budget 

2. Controlling progress of the project 

a. Collecting information about tasks realization  

b. Reporting the project status 

c. Difference analysis between base plan and current project status 

During the course you will learn how to exploit the system to efficiently improve 

realization of your project management tasks.  

First glance at Project Professional 2010 workspace 

Project professional is a part of Microsoft Office family; therefore it shares the 

same clear and user friendly design. 
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Fig. 1. Workspace of Project Professional 2010  

Fig. 1. presents basic layout of Project Professional 2010 workspace. It consists of 

four main elements: 

Menu bar consists of list of all basic functions available in the system arranged in 

six main groups: 

• File – its section called backstage as it consist of functions for project file 

management (creating, opening, saving, printing etc.) and does not serve 

any function that interfere a content of the project 

• Task – set of actions supporting project task definition (creating, editing, 

formatting, linking, etc.) 

• Resource – dedicated for resource management (defining, assigning, work 

planning, etc.) 

• Project – section related with entire project and parameters definition, 

defining subproject and managing with multiple projects  

• View – set of functions controlling content of the workspace and style of 

presentation 

• Format – set of functions allowing control of project appearance (colors, 

information depicted on the Gantt graph, etc.) 
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Ribbon is a special toolbar that contains speedup buttons that lunch linked 

actions. Set of buttons available on the panel depends on selection of particular 

position in the menu. Compare two set of actions for Task and View menu 

selection presented on Fig. 2. 

 

Fig. 2. Actions available on control panel for Task and View menu selection. 

You will learn the role of selected actions during that course.  

The main working panel consists of two subpanels: 

1. The table 

2. Gantt diagram 

In the table you can add, edit, and remove the position such as: tasks or 

resources. Set of columns in the table depicted on Fig. 1. is a default set available 

for a task definition. You will learn how to select other tables and how to redefine 

list of columns afterward. 

Gantt diagram is a graphical representation of the plan and is strictly linked with 

the table. Bars visible on the diagram relate to the respective tasks entered in the 

table. 

Timeline shows overview of entire project. You can add selected tasks to timeline 

to control their position and progress. It is also possible to export timeline in a 

form suitable for email or presentation. 

Some additional information regarding currently selected element of action being 

performed are displayed on Status bar at the bottom of the workspace.  

If you are not sure what is a meaning of particular action of object you can always 

reach context help by placing a mouse cursor right over the button (object) and 
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leaving it there for a while. Hint regarding the topic will appear on the screen 

(Fig. 3). 

 

Fig. 3. Hint information on pointed button 

Hint 

Some of the actions can be launched using keyboard shortcuts. You can 

learn the shortcut from particular action help or hint (see Fig. 3) or you can 

access list of all shortcuts in Project Professional Help – press F1 and enter 

“keyboard shortcuts” in search box (see Fig. 4). 

 

Fig. 4. List of keyboard shortcuts in Project Help 
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Creating new project 

To start your work on your project you have to begin with creating a project. 

Similar to all other MS Office products Project Professional opens with new empty 

document. All the operations you can do with your document such as saving, 

printing, you can access under File menu.  

It is recommended to save the document at the very beginning of the work. 

Defining the project parameters actions are accessible on the Project Ribbon. 

Action Project Information opens Project Information dialog (see Fig. 5) consisting 

of some essential parameters: 

• Start date – you can enter project starting date here only for project 

scheduled from start date (see Schedule From description); 

• Finish date – you can enter project finish date here only for project 

scheduled from finish date (see Schedule From description); 

 

Fig. 5. Defining project parameters 

• Schedule from - is an option that controls a way of task scheduling. There 

are two options available: 

• Project Start Date – recommended for project that has known starting 

date and no constraint on the project deadline is put. The first task 

starts on Start date and dates of all other tasks are calculated 

subsequently according to their duration and relations. Finish date of 
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the project is calculated automatically as the finish date of the last 

task.  

• Project Finish Date – recommended for project that has known finish 

date and all tasks have to be planned to finish before the date. The 

finish date of the last tasks is fixed and dates of all other tasks are 

calculated automatically by pushing backward as the tasks are added. 

 

Fig. 6. Calendar management dialog 

• Calendar – allows to select working and free days along with calculating 

the number of working hours during the week. There are three 

predefined options: 

o Standard - five working days per week (from Monday till Friday);  

8 working hours per working day (shift from 8:00 to 17:00 with 

one free hour for lunch) 

o Night shift – five working days per week (from Monday till Friday);  

8 working hours per working day (night shift from 23:00 to 8:00 

next day with one free hour for lunch) 

o 24 hours – no free days, 24 working hours per working day 
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You can change settings selected calendar or create your own. To do so, click 

Change Working Time on Project Ribbon to open Change Working Time dialog 

(see Fig. 6.) 

To create new calendar press Create New Calendar button and type a new name. 

Next select if you prefer to create new empty calendar or make a copy of existing 

one to introduce some amendments by selecting one of the options.  

To set general pattern of working days select Work Weeks  tab and click Details 

(see Fig. 7). You can set working hours for each week day separately either by 

selecting one of two predefined patterns or by entering your own range of 

working hours.  

 

Fig. 7. Setting working hour template 

Notice that nonworking days as well as nonworking hours are grayed on the Gantt 

diagram. They are excluded from calculation of duration of the tasks (compare 

duration of the two tasks depicted on Fig. 8. with a length of the bars drown on 

Gantt diagram). 

 

Fig. 8. Extending task duration by nonworking days 
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Exercise 1 

You plan to spend your holiday with your friends in one of beautiful venues 

abroad. You need to arrange the plan with your friends and do some preparations 

to avoid any unwanted surprises.  

1. Create a New Project and save it. Because all of the work on the project 

will be realized in your spare time, please define a new calendar for it. Let 

it consists of six working days in a week, from Monday till Saturday.  

2. Set working hour as follow: 

a. Start at 6:00 p.m. finish 10:00 p.m. (from Monday till Friday) 

b. Start at 10:00 a.m. finish 2:00 p.m. (on Saturday) 

3. Set the calendar as default for the project. 

4. Set start date to 1 May. 

Entering New tasks 

Project is a set of ordered tasks that have to be realized by the project team. 

Every task is characterized by its: 

• starting date (optionally time in more detailed projects) 

• duration 

• relation with others tasks 

• resources required for its realization 

During the lesson you will see how those parameters among each other and how 

changing one of them affect others. 

All the operations on tasks you can do by editing Task table. Scrolling and 

browsing the table is possible as it took place in Excel.  

It is recommended to switch to Task Ribbon while filling the tasks table as 

all the options essential for task definition are available there. 

To enter new task just place the cursor at given raw and type the name of the task 

in appropriate column.  
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Hint. There is no restriction or rule put on the task name format. Nonetheless it is 

recommended to use short names to simplify its displaying on the screen as well 

as in any reports on the project available in the system. 

Three of four aforementioned parameters of the tasks are accessible right in the 

table. To define them just move the cursor to desired column ant type required 

value. 

Duration of the tasks is a time required for its realization. It is essential to enter 

the duration at the very beginning as that value can be updated automatically 

later as the result of manipulation with resources assigned. You will learn how 

assigning resources can affect predefined tasks parameters during next lesson.  

There are number of formats you can use for entering duration (see Fig. 9) ex.:  

• minutes,  

• hours,  

• days,  

• weeks,  

• months. 

 

Fig. 9. Defying task modes, durations, and starting dates 

You can enter the value of Start date or Finish date of the task manually or 

you can order the system to calculate it automatically  by selection respective 

Task Mode.  

Notice that the first three tasks on the Fig. 9. are scheduled automatically and 

they start at the first day of the project. Next two tasks are planed manually by 

selecting Manually Schedule mode and entering their starting dates. The colors of 

tasks in both modes differ.  

14



Defining task predecessors 

More advanced method of scheduling requires defining relation among the tasks. 

The relation indicates the sequence of tasks realization. In the most intuitive 

version each can be started as soon as all its predecessors are finished. To define 

sequence all the subsequent tasks must be set to Automatic Scheduled mode, 

while the mode of the first one does not play any role. To set the sequence you 

have to enter predecessor’s id in the respective column (see Fig. 10). 

 

Fig. 10. Defining a sequence of the tasks. 

You can define more than one predecessor for each task using semicolon to 

separate the ids.  

Exercise 2 

1. Propose a list of tasks that have to be done before your holiday, including 

meeting with friends, creating list of wishes, discussing pro and cons, 

looking for desired location, searching for the best connection, 

reservations etc.  

2. Estimate time needed for tasks realization. 

3. Set dependencies among the tasks.  

Exercise 3 

1. Change Scheduled from parameter of the project to Project finish date 

and set Finish date to 1 July.  

2. Compare start and finish dates of the tasks and the project and analyze 

scheduling algorithm.  
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Defining advanced parameters 

All the task parameters are gathered in Task Information dialog (see Fig. 11). You 

can access the dialog by pressing Information button at Task Ribbon. The 

parameters are grouped in six tabs. 

 

Fig. 11. Task information dialog.  

General 

General tab consists of parameters such as names, duration, dates and task mode 

discussed earlier. Some extra parameters: 

• Display on Timeline allows adding the task into the timeline panel; 

• Hide Bar hides the bar of the task on the Gantt diagram; 

• Estimated indicates if the duration of the task has been set and do not 

need further consideration or it has been just estimated and further 

updates are possible or obligatory. 

Predecessors 

Predecessor tabs presents table of predecessor listed with their ids and names. It 

is possible also to choose type of relation linking the tasks: 
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• Finish to start – (default) the subsequent task starts when the antecedent 

task has been finished 

• Start to start – start date of the task is the same as start date of 

predecessor  

• Finish to finish – the task is finished at the same moment when 

predecessor 

• Start to finish – the task must be finished when linked task is started. 

It is also possible to define lag time between the tasks.  

Advanced 

The tab consists of set of constraint parameters that together with dates and 

duration parameters control scheduling process.  

Deadline is the last date when the task has to be finished. There is a following 

difference between Finish date and Deadline. By entering finish date you schedule 

the task manually and its term is fixed. By setting deadline scheduling can be 

realized automatically but finish date cannot extend deadline. 

Constraint type options govern a way of scheduling. For some option Constraint 

date is required (Fig. 12). 

 

Fig. 12. Setting Constraints 

Notes 

Notes tab is a place you can enter any information on the task in a form of free 

rich text. It is a matter of agreement how you can use the notes. One of the 

propositions is to list here task products.  
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Exercise 4 

1. Analyze your project and change Relation type between selected tasks. If 

necessary insert new tasks. 

2. Set deadline for selected task. 

3. Try to change Constraint type and Constraint date of selected tasks.  

4. Analyze how changes affect schedule.  

Defining subtask and hierarchy of tasks 

Creating project plan is a work you can realize in phases. At the beginning you can 

define just outline of the main tasks that are to be realized. Afterward you can 

add some extra tasks or split previously defined one into number of subtasks.  

To define subtask for selected task just insert line right below the task and fill all 

necessary parameters. Next click Indent task button to move the task left and 

makes it subtask (Fig. 13).  

 

Fig. 13. Defining subtasks 

Hint. You can indent more than one task at the time by multiple selection 

several lines 

Note how subtask and main task are depicted on the Gantt diagram.  
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Define subtasks for selected task in your project. 

19

Important. 

Duration of a task that consists of number of subtasks is calculated 

automatically depending on number of subtasks, their duration and 

dependencies. You cannot set it manually. 



Module 2. Resources 

Contents 

• Resources repository 

• Key parameters of resources 

• Assigning resources to tasks 

Resources repository 

All projects are realized with means of resources. There are three types of 

resources that can be defined in MS Project. 

Work – all the resources that can be employee to do some work in your project. 

That can be human resources or machines, engines etc. Common denominator for 

all the resources of that type is that you can evaluate cost of their use per hour. 

The other important parameter is limit of usage rate. 

Material – all the resources that you need for realization of particular tasks and 

therefore you have to purchase them. 

Cost – virtual or temporary resource type. You can not assign any real costs with 

that type of resource. You can define it to indicate that you or someone 

responsible for defining list of resources and their costs have to update that 

information i.e. define real resources. Cost resource can substitute both 

abovementioned types of costs. 

The most convenient place of resource definition is Resource repository/Resource 

Sheet.  

To access the Resource Sheet select Resource tab and optionally check Resource 

Sheet in Team Planner as depicted on Fig. 1. 
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Fig. 1. Opening resource management sheet 

Resource sheet presents most of all essential information on resources.  

Basic resource information 

• Resource name – unique name of particular resource 

• Type – type of resource (ex. Material, Work) 

• Material – a unit of measurement ex. pcs, Kg, etc. It is valid only for 

material type of costs. 

• Initials – abbreviation of the resource used clear and short way of 

visualization of the resource use in reports etc. 

Cost of use and resource balancing 

• Max – maximum available capacity given in percent, valid only for work 

type of resources. The parameters that limits working time of a given 

resource. If you plan work for the resource that exceeded the limit you 

will be warned.  

• Std. Rate – Standard cost of use. Depending on the type of resource it 

takes two forms: 

o Cost of work per working hour – option valid for work type of 

resource. If you plan to engage team consisting of professionals of 
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different expertise you may want to define different salaries rates 

for them. You can use that field to define the rate for their work 

respectively. Note, that rate given here is defined per hour or any 

other time measure (day, months, etc). 

o Total cost of purchase or rent – option valid for material type of 

resource. If you need to purchase or rent some material resources 

such as different kind of software, computers or cars, you can 

define here costs of their purchase or rent.  

• Cost/Use – is amount of money you have to pay every time resource is 

used. For example, you are planning to organize series of presentations 

for your customers. To ensure most comfortable atmosphere you are 

planning to provide catering. Every time catering appears in your project 

you have to pay for it.  

• Accrue at – is a parameter that control when the cost are charged to the 

task. There are three options available: 

o Start – costs charged at the very first day of the task; 

o End – costs charged at the end of the task realization; 

o Prorated – costs are spread uniformly through entire task 

timeline. 

Overtime costs 

It is possible to engage resources to work over standard working time and working 

time limit. Usually it causes necessity to pay extra for overtime work. To define 

rate of pay for overtime work you can fill Overtime parameter for Work Type 

resources. 
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Fig. 2. Example of resource pool definition.  

Exercise 1 

You are resource manager in a project that aims at development and 

implementation Internet Shopping system.  

1. Define resource pool.  

2. Figure out what kind of specialist you have to engage in the project. 

3. Define what kind of software for designing and development you need.  

Define at least three resources for each resource type. 

4. Estimate costs for all resources and model of cost charge. 

Defining calendar 

Working time for all resources are calculated depending on calendar assigned. 

You can define the calendar for each resource respectively. 

Calendar defines working hours, working days in a week and number of working 

days in a month.  
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Fig. 3. Working time defined for a resource. 

More details on a calendar and working time specification refer to information in 

Classes 1.  

Assigning resources to the tasks. 

Having defined resource pool you can assign resources to tasks. The easiest way 

to do that is filling Resource column in Gant Chart (Fig. 4). 

Hint 

You can assign more than one resource to a task. You can do so just by 

multiple selections checkboxes in the resource list. 

More advanced method of defining resource – task relations will be presented in 

Class 3. 
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Fig. 4. Assigning a resource to a task. 

Exercise 2 

1. Create draft task list of your project consisting of at least five stages.  

2. Assign resources from you resource pool to the tasks respectively to their 

competences.  

Other resource information. 

All above mentioned data on resource you can enter in Resource sheet.  

Some extra information can be also accessed via Resource Properties dialog 

(Fig. 5). You can open the dialog by double-clicking resource’s rows in Resource 

sheet or by pressing Resource Information button on Resource ribbon. 

Generic resources. 

Usually while defining resource pool project leader or resource manager do not 

know names of team members but they can specify what kind of expertise they 

have to master. For example, when you plan implementation of Enterprise 

Resource Planning system in a production company you need cooperate with 

consultants, system architects, administrators etc. Resources define by their 

specialization are called Generic (see Fig. 5).  
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Common practice is to define Generic resources while creating project plan.  

When the plan is accepted and the project is launched, project manager can start 

to collect required project team. In a case of large projects, tasks of collecting the 

team can be also handed over to people responsible for realization of particular 

tasks.  

At that stage, the resource pool can be extended with resources representing real 

project team members specify with their names.  

There is no rule saying how many real resources you can add to the pool to 

substitute one generic resource.  

The only restriction is that total working time of all real resources should not 

exceed the respective generic resource’s working time.  

 

Fig. 5. Resource Information dialog 
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Exercise 3 

1. Update Resource Sheet with names of your colleagues. Try to add more 

names that generic resources number (of working type) that you have 

already added. 

2. Go to Gantt chart and substitute Generic resources that have been 

assigned with names of your colleagues respectively to their 

competences. 

Advanced resource’s cost management 

Apart from defining overtime rate for work-type resource there exists also even 

more flexible way of defining exception for cost definition. It is possible to create 

a list of days with extra cost definitions.  

The list is accessible in Resource Information dialog on tab Cost.  

In example depicted on Fig. 6. two exceptions have been defined for Project 

manager that alter standard cost definition. 

 

Fig. 6. Altering resources costs by entering exceptions 
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Resource availability 

While creating project plan that spans over long period of time (couple of months 

and years) project manager have to take into consideration limited availability of 

particular team members that can be caused by holiday plans or temporary 

absence. Naturally the gaps in accessibility of the resource can affect realization of 

tasks that overlap them. It is important to be aware of possible consequences (ex. 

delay of task realization) as soon as possible.  

Project manager can define list of exceptions in Resource Availability grid in 

Resource Information dialog.  

 

Fig. 7. Defining resource availability 

Note that a list of time ranges should be continuous and subsequent periods 

cannot overlap. “NA” means that you do not define starting or finishing date.  

Notes 

You can add some notes and remarks on a resource accessing Notes tab in 

Resource Information dialog. The Note is a free text with some style formatting 

properties such as bulleting or numbering.  

Importing resources 

MS Project system provides effective integration with ActiveDirectory of a domain 

your computer belongs to or with Outlook address book on your workstation. You 

can access list of users defined in those repositories and download selected 

positions to your resource repository.  

To access ActiveDirecotry or AddresBook click AddResources on the ribbon.   
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After the import is finished, some extra information on resource are downloaded 

such as e-mail addresses, etc.  

 

Fig. 8. Importing resources from ActiveDirectory of AddressBook 

Team planner 

While you assigned the resources to the project tasks you can easily control when 

particular resource is required in the project by opening Team planner. The team 

planner presents table of resources along with Gantt chart depicted over a 

timeline. 

Analysis of the chart allows tracking sequence of the work of each team member. 

Dates can be read directly from the timeline while some additional information is 

available on pop-up message that opens when the mouse cursor is located just 

over the task bar (Fig. 9).  
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Fig. 9. Controlling resource work plan with Team planner 

When summary work time allocated to a particular resource exceeds their work 

time limit a name of the resource in the table as well as respective task’s bar is 

highlighted in red color. That feature is supposed to provide warning information 

for a project manager or resource planner (methods of resource work balancing 

are subject of Classes 3). 

You can easily switch order sequence of the resources and apply range filters on 

the resource list by pulling down menu available under Resource Name column 

title bar (Fig. 10). 

 

Fig. 10. Sorting and selection of the resources in Resource Sheet 
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Exercise 4. 

1. Define overtime costs for all of resources in the project. 

2. Define holidays and any other periods when a particular resource want to 

be available for all of named resources.  

3. Define several periods with limited availability for selected resources. 

4. Analyze results of your amendments in Team planner. 
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Module 3. Advanced Method of Resource Management 

Contents 

• Alternative method of resource assigning 

• Relation among work, time, resources  

• Over allocated resources 

• Leveling resources 

Alternative method of assigning resources and tasks 

An alternative very comfortable way of assigning resources to task is splitting 

Gantt Chart working panel into two vertically oriented panels. To do so you have 

to: 

1. click Details button on the Gant ribbon, 

2. place mouse cursor over the bottom panel, pop-up menu (right mouse 

button click) and selecting one of the options consisting keyword 

resources. 

The bottom panel (Task Details Form) consists of set of information about the 

tasks accessible in Task Information dialog; nonetheless panels stay visible on the 

screen not forcing to open the dialog every time you need to access the additional 

task information. 
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Fig. 1. Assigning resources in Task Details Form 

Using Task Details Form allows adding required resources in resource list (left side 

of the panel) by selecting them from drop-down list.  

Defining resource work 

You can define how many instances of resources you need in your task by 

entering required number in the Units column in the Resource list. Units are 

entered in percent of usage. For example: 

• 100% means that the respective resource is required fulltime over entire 

task period. 

• 50% means that you need to engage the resource only half time for given 

task. Engaging resource in halftime, 25 or even 5% is a simple way of 

indication that you need the resource for consultancy.  

• 200% means that you plan to engage two resources of given competence. 

It is common to assign the project manager to all of the tasks in small 

amount of usage as they also participate somehow in their realization. 

Note that a work time of the resource is automatically calculated when you add 

the resource. The resulting value is a function of the duration of the tasks and the 

units of the resource. 
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Note also that when you are filling the resource list by adding new entries the 

total worktime of all resources increases while the duration of the task is fixed. 

That is correct behavior and it is essential to understand a concept. 

• When you create a task and enter duration parameter you assume that it 

is a time required for its realization by a team that may consists of 

number of resources.  

• When you fill the resource list for the very first time for a particular task 

you define total worktime needed for task realization. 

Notice how information on the resource usage in the task is depicted on Gant 

Chart panel (Fig. 2). 

 

Fig. 2. Resource usage  

The other method to define resource list is using Assign resources dialog (Fig. 3). 

The dialog is accessible under Assign resource button on Resource ribbon. 

In the dialog you can browse list of all resources defined in the resource 

repository. You can assign resource just by entering usage (Units column) more 

that 0%.  

Note that column costs provide information about costs that are generated by the 

resource. It is very convenient way of controlling budget while creating the 

project plan. The resulting cost is a function of the task duration, resource 

engagement (units) and resource’s cost defined in resource sheet.  

Replace button is a function that allows easily replace a particular resource with 

the other one.  
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It is very convenient when  

• you have to cope with a set of resources of similar competences and 

different costs looking for best possible team for the task; 

• you are replacing generic resources with their named counterparts. 

Some additional information on allocation of the resources is available under 

Graph button.  

The lower panel (Resource graph) presents details of allocation of each resource.  

Note, that you have to shift Resource graph to see information on a 

particular resource if more than one are assigned to the task. You can do 

that by scrolling mouse button up and down. 

 

Fig. 3. Using Assign resources dialog 

35



Exercise 1 

Create a project plan for marketing action for newly developed product that is to 

be introduced to the marked. You have to prepare appropriate advertisement and 

commercial actions.  

1. work out draft project tasks plan; 

2. define list of resources: 

a. plan defining teams (at least three resource entries) that works on 

a selected tasks, 

b. plan to define for some resources more that 100% units, 

c. plan to use some resources for consultancy (units defined less 

than 100%); 

3. assign resources with tasks. 

Time – Work – Resource relation 

While your resource list has been defined the total workload is fixed. Further 

modification of resource assignments can cause update of the duration time of 

the task.  

 

Fig. 4. Fixed relation between work resource and time. 

• Adding new resource or increasing resources units causes reduction of 

task duration; 
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• Removing resource or reducing resource’s engagement causes extending 

task duration. 

Exercise 2 

Update the project from Exercise 1  

1. Reduce the project duration at least 30%. 

2. Do not reduce workload of the tasks. 

3. Extend resources pool if necessary. 

4. Increase number of resources assigned to the tasks. 

Resource pool 

If there is predefined resource pool you can use it by importing it. Steps of the 

procedure are: 

1. opening the file consisting predefined resource pool, 

2. switching to the active project window, 

3. clicking Resource pool button on Resource ribbon and selecting Share 

resources, 

4. selecting Use resources from… in Share resources dialog and selecting 

project file containing resource pool. 

Tip. If you are project manager or resource manger and you have fixed list 

of available resources it is convenient to define the resource pool file and 

importing the list to newly created projects. If you have got more than one 

competence teams you can create repository of files one for each of the 

team. 

Over-allocating resources 

Defining usage of a particular resource can cause receiving warning message 

about overallocation of the resource (Fig. 5).  The message is result of exceeding 

the limit of maximum capacity of given resource. Providing that the total 

workload is fixed and you cannot decrease you have to resolve the problem 

managing with resources. There is couple of ways to solve the issue: 
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• Increasing the maximum capacity of the resource in the Resource Sheet. 

That option is valid when increasing capacity is realistic for example, when 

you are defining capacity of generic resources and you have got several 

resources of given type for your disposal. Setting max capacity to 1000% 

means planning work for team consisting of 10 members; 

• Replacing overallocated resources with other. That solution works if you 

have got alternative counterparts that are free at the time of allocation; 

• Adding extra resources; 

• Leveling resources (details on leveling in next section); 

• Combination of all above listed options; 

 

Fig. 5. Resource over-allocating message 

A convenient way of determining period of time when an overallocation occurs is 

screening timeline with Resource sheet (Fig. 4). You can easily determine level of 

overallocation from allocation bars. The horizontal solid black line presents 

Maximum capacity level defined for the resource. The red part of the bar states 

for overallocation.  
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Fig. 6. Controlling of overallocation on Resource Graph 

Note. When you point out Resource graph with a mouse pointer Format 

ribbon provide you some useful functions for graph formatting and scrolling 

through the list of the resources. 

Resource remaining availability 

When you are looking for free resource you need to add to the working team at a 

particular time you can use Resource graph and Remaining availability graph. To 

open the graph: 

1. switch to Resource sheet to get the full list of all resources in the project, 

2. split the panel (click Details), 

3. open Resource graph right click on the bottom panel title bar (vertical line 

on the left of the panel), 

4. select Overallocation (right click on the Resource graph panel to access 

drop-down menu). 
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Fig. 7. Remaining availability on Resource Graph 

Leveling resources 

Alternative method of eliminating overallocation of the resource is updating a 

time of the task realization by: 

1. shifting start date of the task to a moment when required resources are 

available, 

2. splitting the task into two or more pieces planning pause in the work in 

the moments when required resources are busy, 

3. extending realization time (increasing workload). 

All above operation and even more you can do manually or automatically by 

launching Level Resource function.  
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You can run the function for one resource currently selected on Resource sheet or 

Resource Graph or for any other range of resources including leveling of entire 

pool (Fig. 8). 

 

Fig. 8. Allocation of the PR manager before and after leveling  

(upper and bottom graph respectively) 

 

Carefully inspect results of auto leveling as the process can cause serious 

amendments in the task scheduling. In highly complicated and compound 

projects consisting of many tasks and dealing with large resource pool it is 

recommended to solve allocation conflicts manually or limit auto leveling to 

narrowed range of the resources.  
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Exercise 3 

Update the project from exercise 1 and 2.  

1. Define some limitation of availability for selected resources at the time 

they are engaged in the realization of some tasks.  

2. Save a copy of the project and solve availability conflicts manually by: 

a. postponing tasks,  

b. splitting tasks, 

c. replacing resources. 

3. Open original version of the project and level resources automatically. 

4. Compare obtained results. 
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Module 4. Project Budget 

Contents 

• Reviewing Cost Information 

• Reducing Project Costs 

• Project Fiscal Year 

• Saving the Project Plan 

Reviewing Cost Information 

All projects cost money. Whether you’re planning a small or big project, the 

project budget will be a key factor in all the planning and tracking decisions you 

make. Knowing the value of the budget shall be checked with the planned costs.  

After added tasks, resources, and any associated costs (see module 2), we can 

check the total cost of project. 

Viewing the total project cost in the project summary task 

Apply the Cost column. With a task-oriented view like the Gantt Chart visible, in 

the Data section, click the down arrow to the right on column “Add new column”, 

and then, from the drop-down list, choose Cost. 

When you create a schedule we are only interested in column Costs and 

Overall costs. Columns such as the Cost variance and Actual costs will be of 

interest to us, when the actual data will be entered on the execution of the 

project. 

The project summary task is a great place to spot the total planned project cost, 

because it rolls up the totals for all tasks.  

With a task-oriented view like the Gantt Chart visible, choose Format → 

Show/Hide and then turn on the Project Summary Task checkbox and Summary 

Task checkbox (see Fig 1). 
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Fig. 1. Adding a new column and options in Show/Hide 

Viewing the total project cost in Project Statistics 

To get to the single number that indicates your total project costs, use the Project 

Statistics dialog box as follows: 

Choose Project→ Properties→ Project Information and click the Statistics button. 

The Project Statistics dialog box is shown in Fig 2. In the Cost column, review the 

value in the Current field, which is the forecasted cost for the project as currently 

planned. 
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Fig. 2. Project statistics with costs 

Seeing Costs for Tasks, Resources, and Assignments 

Total cost for a task. First apply the Cost table (View→ Data→ Tables→ Cost) to a 

task view, and then, in the Total Cost column, check the value. The Cost value is 

the scheduled (planned) cost for the task, including all assigned resources (work, 

material, and cost) and any fixed costs.  

Total cost for a resource. Display the Resource Sheet, and then insert the Cost 

field (right-click the table and choose Insert Column) somewhere in the table. The 

Cost value for a given resource is the total cost for the resource for all assigned 

tasks, based on the standard rate, overtime rate, cost/use, or other specified 

resource cost (see Fig. 3).  

Total cost for an assignment. Display the Task Usage view or Resource Usage 

view. As usual, you can either apply the Cost table or insert the Cost field in the 

Usage table. In the Task Usage view, the cost in the resource name row 

represents the cost for the individual assignment - what it costs to have the 

resource assigned to the task. The cost in the task name row represents all 

assignment costs rolled up to give you a total for the task. 
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Fig. 3. Costs for resources 

Reducing Project Costs 

If project costs exceed the budget must verify their value. You can do this by 

looking at the following factors which are tied to the cost: 

Task durations. Review task durations for any that approach the length of 

geologic eras. Durations affect cost because Project multiplies duration by rates to 

calculate cost. 

Cost per use. In the Resource Sheet, look for values in the Cost Per Use column. 

Remember that a cost per use is levied for each task a resource is assigned to. 

Resource rates. Also in the Resource Sheet, review the rates you’ve assigned to 

human, equipment, and material resources. 

Planned assignment costs. Apply the Cost table to the Resource Sheet, and then 

check your resources’ costs on their assignments. The Cost field shows the total 

planned cost for a resource for all tasks it’s assigned to.  
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Cost resource amounts. To easily review cost resource amounts, display the 

Resource Usage view, apply the Cost table, and then group the view by resource 

type (click the down arrow to the right of the Resource Name column heading and 

then, on the drop-down menu, choose “Group by” → Resource Type). To return 

the view to its normal ungrouped arrangement, choose the down arrow to the 

right of the Resource Name column heading and then, on the dropdown menu, 

choose No Group. 

Fixed costs for tasks. In the Gantt Chart view, check any fixed costs for tasks to 

see if they have one or two zeroes too many. Apply the Cost table to the view, and 

then sort by the Fixed Cost field. (Click the down arrow to the right of the Fixed 

Cost column heading and then, on the drop-down menu, choose Sort Largest to 

Smallest to show the highest fixed costs at the top of the view.)  

Adjusting the Schedule 

If you do not find errors cost schedule must be corrected . For this purpose you 

can use: 

Task durations. You’ve already scrutinized task durations looking for possible 

errors. Now see if there’s any way to realistically shorten durations and still get 

the job done. In the Gantt Chart view, make sure the Entry table is visible. You can 

run down the tasks in order or sort the schedule by duration to cherry-pick the 

longest durations for your scrutiny. To show the longest durations at the top of 

the view, choose View→Data→Sort→Sort By, and then, in the “Sort by” box, 

choose Duration and select the Descending option. Turn off the Keep outline 

structure checkbox, and then click Sort. To hide summary tasks, choose Format → 

Show/Hide and turn off the Summary Tasks checkbox. 

Task relationships. Sometimes by linking tasks more aggressively , you can 

shorten the time you have to pay resources while they wait for their next task to 

begin.  

Date constraints. Any constraints other than As Soon As Possible (or As Late As 

Possible for a project scheduled from the finish date) are worth a second look. If 

you have a task with a Must Finish On or Start No Earlier Than date constraint 

applied, resources may be waiting in limbo unnecessarily for the right time to 

work on tasks. Removing that limbo time can help you cut costs. Add the 

Constraint Type and Constraint Date fields to a table, and then sort or group by 

Constraint Type. 
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Adjusting Assignments 

Try also adjusting resource assignments. Here are a few strategies to try: 

• Replace expensive resources with cheaper ones. Consider having your 

more experienced (and probably more expensive) resources mentor your 

less costly resources for a short time on tasks, rather than working the 

entire task. Or use cheaper in-house - perhaps borrowed- resources, 

rather than more expensive outside consultants. On the other hand, 

sometimes hiring temporary contract labor is cheaper than using your in-

house employees. 

• Do away with overtime. If your current schedule involves overtime, see if 

you can adjust assignment to eliminate overtime (on resources that cost 

more for overtime, of course). 

Setting the Project Fiscal Year 

You can set the fiscal year for a project, whether it’s the one your own company 

uses or that of the project customer’s organization. Whether the fiscal year starts 

in January, February , or other months , a project fiscal year can make working 

with financial accounting Department much simpler. 

How to see fiscal year dates in views: 

• Choose File → Options, and then, in the Project Options dialog box, 

choose Schedule. 

• In the Fiscal year starts in box, choose the month in which the fiscal year 

begins. 

• If your fiscal year is named by the calendar year in which the fiscal year 

begins, turn on the Use starting year for FY numbering checkbox (see 

Fig. 4). 
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Fig. 4. Options for fiscal year 
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Fig. 5. Fiscal year 2010 ends in February 2011 

The fiscal year is reflected in the timescale headings of Gantt Chart views and 

usage views, see Fig. 5. 

Saving the Project Plan 

The creation of a baseline closes the phase of planning the project.  Baseline is a 

picture of the project after the planning phase or at the end of another critical 

phase. Baseline is a set of data stored in the same file in which we track the 

progress of the actual data. You can view a variety of information about the base 

plan created, you can also in general they are not present.  

Setting a Baseline 

Project doesn’t set baselines automatically, because it has no way of knowing 

when your plan is ready to be saved for posterity. How to create baseline: 

1. Open the file you want to baseline, and then choose Project → Schedule 

→ Set Baseline → Set Baseline. 

2. Make sure the Set baseline box is set to Baseline, and the Entire project 

option is selected and click OK (see Fig. 6a). 
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Project stores the current values for start, finish, duration, work, and costs in the 

corresponding Baseline fields. The next time you open the Set Baseline dialog box, 

the Set baseline box shows the date you set the baseline (see Fig. 6b). 

a) b) 

Fig. 6. Options for baseline 

Setting Additional Baselines 

An additional baseline is also helpful when a project experiences a big change-an 

interruption to the schedule, a big scope increase, or a spike in the price of 

materials. How to set another baseline: 

1. Choose Project → Schedule → Set Baseline → Set Baseline. 

2. In the Set baseline box, choose the baseline you want to set. Make sure 

the Entire project option is selected and click OK. 

Adding New Tasks to a Baseline 

How to add tasks to a baseline: 

1. In the Gantt Chart or another task-oriented view, select the tasks you 

want to add to the baseline. 

2. Choose Project → Schedule → Set Baseline → Set Baseline. 
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3. In the Set baseline drop-down list, choose the baseline to which you want 

to add tasks, and then select the Selected tasks option. 

4. If you want the values for new tasks to update the summary tasks you 

select, turn on the From subtasks into selected summary task(s) checkbox. 

5. To update all summary tasks with the new task values, turn on the To all 

summary tasks checkbox and click OK. 

Viewing Baselines 

When you initially set a baseline, its values are exactly the same as the current 

Project-calculated field values. 

Choose Project → Project Information. In the Project Information dialog box, click 

Statistics to open the Project Statistics dialog box, which shows top-level summary 

information for the whole project. 

Viewing baseline and current values in a Gantt Chart view 

When you want to compare the baseline schedule to the current status: 

Display the Tracking Gantt view. Choose Task → View → Gantt Chart → Tracking 

Gantt. 

By entering the baseline MS Project will be able to calculate the variance, 

the difference between plan and execution. 

Exercise 

Open the project file made in Module 3. 

1. Check total cost of the project. 

2. Reduce project costs by 10%. Use a minimum of 4 factors. 

3. Determine the fiscal year other than calendar year. 

4. Save the project plan. Create a baseline and an additional baseline. 

52



Module 5. Tracking Progress 

Contents 

• Entering Actual Progress in Project 

• Updating Task Progress 

• Updating the Project Using Resource Assignment Progress 

• Globally Updating the Project 

• Updating Project Costs 

Entering Actual Progress in Project 

Progress information based on what actually happened is usually referred to as 

project actuals. Actuals are made up of data like actual duration, actual start, 

actual work, and percent complete.  

Updating Task Progress 

You can update progress for entire tasks, whether or not you assign resources to 

them. There are three methods for updating task progress: percent complete, 

actual and remaining duration, and actual start and actual finish. 

You can update task progress in several places: 

Mark on Track command. To quickly update the percent complete of specific 

tasks to 0%, 25%, 50%, 75%, or 100%, hold CTRL and click each task that you want 

to update in the list. On the Task tab in the Schedule group, click the 

corresponding percent-complete button, such as 25% 

Complete.  

The Update Tasks dialog box. Choose Task → Schedule → Mark on Track → 

Update Tasks) includes all the fields you might use to update progress. If several 

tasks have the same update values, you can select all the tasks before you open 

the dialog box (see Fig. 1a).  
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a) b) 

Fig. 1. The Update Tasks dialog box and Table options 

The Tracking table. Choose View → Data → Tables and then choose Tracking on 

the drop-down list – (see Fig. 1b) in a task-oriented view is the fastest way to 

enter progress for one task after another. 

Entering percent complete actual duration, remaining duration and 

actual duration and remaining duration 

• In a task-oriented view such as the Gantt Chart view, choose Task → 

Schedule →Mark on Track → Update Tasks. 

• In the % Complete box, type the percent complete for the selected 

task(s). 

• In the “Actual dur” box, enter the actual duration.  

• In the “Remaining dur” box, enter the remaining duration for the selected 

task, and then click OK (see Fig. 2). 
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Under Actual, click the arrow in the Start box, and then choose the actual start 

date from the calendar drop-down menu. Do the same in the Finish box to set the 

actual finish date. 

 

Fig. 2. Options for updating task process 

When you enter an actual duration, the value in the Remaining dur box and 

Duration box doesn’t change immediately. Project doesn’t recalculate the 

fields in the dialog box until you click OK. 

IMPORTANT. When you specify the percentage of completion for a task, Project 

calculates the actual duration and remaining duration according to the formulas 

Actual Duration = Duration * Percent Complete and Remaining Duration = 

Duration - Actual Duration.  

When you specify the percentage of work complete for a task, Project calculates 

the actual work and remaining work according to the formulas Actual Work = 

Work * Percent Work Complete and Remaining Work = Work - Actual Work.  

Project calculates the completion percentage of a summary task based on the 

progress of its subtasks. You can also manually enter the percent work complete 

on a summary task.  

Project calculates the percentage of work of a summary task that is complete 

based on the progress of its subtasks. You can also manually enter the percent 

work complete on a summary task.  
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Updating the Project Using Resource Assignment Progress 

When resources are assigned to tasks, you can take progress updates to a more 

detailed level of tracking. Instead of showing progress on the task as a whole, you 

can show progress on individual assignments within the task. 

Entering percentage of work complete, actual work complete and 

remaining work 

• Display the Task Usage or Resource Usage view. Choose Task → View → 

Task Usage or Resource Usage. 

• In the Task Usage view, Project lists the assigned resources under each 

task. In the Resource Usage view, Project lists the assigned tasks under 

each resource. 

• Select the assignment whose percentage of work complete you want to 

update and Double-click the assignment. 

 

Fig. 3. Options in Tracking tab 

• Select the Tracking and update several fields for the individual assignment 

(as it shown in Fig. 3).  
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The Tracking tab includes the Actual work  and Remaining work boxes. Any 

existing values for actual and remaining work appear in the boxes. The value in 

the Work box (scheduled work) is the sum of actual work and remaining work. (In 

Project, the Work field represents scheduled work - the total of actual work 

performed and the current estimate of remaining work. 

Entering actual work by time period 

How to enter actual work by time period: 

1. Display the Task Usage or Resource Usage view. 

2. Display Actual Work in the time-phased portion of the view by choosing 

Format → Details and turning on the Actual Work checkbox. 

3. In the table area, select the assignment whose actual work you want to 

update. 

4. To display the cells for the assignment in the time-phased portion of the 

view, choose  

Task → Editing → Scroll to Task.  

5. In the Act. Work field in the assignment row, type the actual work values 

in the appropriate time periods (see Fig. 4). 
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Fig. 4. Added current value of work 

Updating the Project Globally 

Rescheduling unfinished work in the project 

 
Fig. 5. Options for update project 

1. Display any task-oriented view. 

2. To reschedule only certain tasks, select them and then choose Project → 

Status → Update Project. Select the Reschedule uncompleted work to 
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start after option, and then type the date when work should resume (see 

Fig. 5). 

Updating the project as scheduled 

1. Display any task-oriented view. 

2. Choose Project → Status → Update Project. 

3. Make sure the Update work as complete through option is selected. In the 

date box, enter the cutoff date for updating as scheduled. If you want 

Project to update tasks with partial percent complete, select the “Set 0% - 

100% complete” option. 

Updating Project Costs 

Projects can potentially have up to five different sources of costs: human 

resources, equipment, materials, cost resources, and fixed costs for tasks. Each of 

these costs needs actual cost information before you can see where you stand 

against the project budget. 

Project automatically updates the actual cost (see Fig. 6) field as you enter actual 

work information (actual start and finish, percent complete, or actual work). 

If the view does not contain a column should be added, as in exercise Viewing the 

total project cost in the project summary task from module 4. 
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Fig. 6. Reviewed the actual cost 

Exercise 

Open the project file made in Module 4. 

1. Perform an update of the project to 25%, 35%, 55% by various methods. 

2. View current cost of the project. 
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Module 6. Reporting on Projects 

Contents 

• Text-Based Reports 

• Visual Reports 

Text-Based Reports 

Project assigns reports to several categories, which may be different from the way 

you group them. To basic group are text-based and visual reports. To see the text 

reports choose Project → Reports Reports (see Fig. 1) 

 

Fig. 1. Groups of text reports 

Overview reports 

Project Summary shows the same high-level information as the Project Statistics 

dialog box: baseline, scheduled, and actual values for dates, duration, work, and 

costs. At the bottom of the report, task status shows the number of unstarted, in-

progress, and completed tasks. The resource status shows the number of 

resources, and how many are overallocated. 
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Top-Level Tasks shows tasks at the outline’s top level. It shows the planned 

schedule with information straight from the Summary table: Duration, Start, 

Finish, % Complete, Cost, and Work. 

Critical Tasks Status shows work and remaining work for critical tasks. You can 

include more fields, like baseline and actual costs, to see whether the critical path 

is on track. 

Milestones shows start and finish dates, so you can see when significant 

achievements or events occur.  

Critical Tasks lists all critical tasks along with their successors, so you can see how 

delayed critical tasks may affect other tasks. 

Current activity reports (selected) 

Unstarted Tasks shows tasks that haven’t started, whether they’re on time, early, 

or late. It is useful near the end of a project. 

Tasks Starting Soon shows tasks that start or finish during the date range you 

specify, so some tasks may have already started. 

Should Have Started Tasks. This report asks for a date, and then shows tasks that 

should have started by then but don’t have any actual hours recorded. 

Completed Tasks lists tasks completed each month, which is a great way to boost 

team morale by showing them how much they’ve accomplished. 

Assignment reports (selected)  

Who Does What shows the tasks assigned to each resource. Use it if you lose a 

resource, to find the tasks you have to reassign. 

Who Does What When breaks down the information in the Who Does What 

report period by period. The Who Does What When report includes all resources 

and all assignments for the entire project duration. 

To-Do List shows each person what she’s supposed to work on during each week 

of the project. 
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Workload reports 

Task Usage shows task like the Task Usage view. You can use it to see the work for 

each task week by week. 

Resource Usage. Shows task like the Resource Usage view. It shows hours 

assigned week by week. 

Generating Text-Based Reports 

1. Choose Project → Reports → Reports and double-click one of the report 

categories. 

2. Double-click the report you want to generate and print it.  

The Print page in the Backstage view has typical print settings like the printer, 

date range, paper orientation, and paper size (see Fig. 2). 

 

Fig. 2. Print settings 

Customization options in Text-based reports. 

1. Choose Project → Reports → Reports and double-click Custom. 

2. Select the report you want to copy, and then click Copy. 
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3. In the Name box, type a name for the report. 

4. Modify the report to show the information you want, and then click OK to 

add the report to the Custom Reports dialog box Report list.  

 
Fig. 3. Options for customizing 

5. Depending on the type of report you’re customizing, the corresponding 

dialog box opens (see Fig. 3). 

Visual Report 

The report templates are divided into six categories in the Visual Reports 

(selected).  

Task Usage 

Cash Flow. Use this report to view a bar graph with cost and cumulative cost 

amounts illustrated over time. 

Assignment Usage  

Earned Value Over Time. Use this report to view a chart that plots AC (actual cost 

of work performed), planned value (budgeted cost of work scheduled), and 

earned value (budgeted cost of work performed) over time. 
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Baseline Cost. Use this report to view a bar graph with baseline cost, planned 

cost, and actual cost for your project illustrated across tasks. 

Baseline Work. Use this report to view a bar graph with baseline work, planned 

work, and actual work for your project illustrated across tasks. 

Budget Cost Report. Use this report to view a bar graph with budget cost, 

baseline cost, planned cost, and actual cost illustrated over time. 

Resource Usage 

Resource Cost Summary. Use this report to view a pie chart that illustrates the 

division of resource cost between the three resource types: cost, material, and 

work. 

Resource summary 

Resource Remaining Work. Use this report to view a bar graph with remaining 

work and actual work for each work resource, illustrated in work units. 

Generating a Visual Report 

Choose Project → Reports → Visual Reports. Select the visual report you want to 

use and click View. 

An Excel-based visual report starts Excel and then sets up an Excel file with the 

data cube attached to it. The Excel spreadsheet has two worksheets. The Chart1 

(see Fig. 4) worksheet is a pivot chart - a graph that displays the data. The second 

worksheet (see Fig. 5) is a pivot table, which contains the cube data. 

When you open a visual report in Excel, you may see only the pivot chart. To 

display the pivot chart tools and the PivotTable Field List, click anywhere in the 

graph. When the visual report is open in Excel, you can add, remove, or change 

the fields that appear in the pivot chart. The PivotTable Field List is a task pane to 

the right of the pivot chart (see the red rectangle in Fig. 5). 
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Fig. 4. Graph that displays the data 

 

Fig. 5. Pivot table with data 
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Hint 

Select fewer than six dimensions for your report. If you select more than six 

dimensions, report performance is significantly decreased. 

Filtering the data that appears 

To switch the report to task filtering, drag Tasks from the Row Labels box into the 

Report Filter box. To select specific tasks to display, in the pivot table, click the 

Tasks down arrow. To select a specific task as the filter, like one phase of the 

project, expand the tasks until the one you want is visible. 

Summarizing and drilling down 

Drilling down into details or soaring up to summary views is almost effortless in 

visual reports. Click expand buttons (+) or collapse buttons (–) on the pivot table 

worksheet. Whatever you can see in the pivot table is what you see in the pivot 

chart (see Fig. 6). 

 

Fig. 6. Summarizing and drilling down data from pivot table 
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Exercise 

Open the project file made in Module 5. 

1. Follow the 3 reports from the Text-Based Reports group. Discuss the 

results. 

2. Follow the 3 reports from the Visual Reports group. Follow the drilling 

down and up process. Discuss the results. 
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Module 7. Working on Multiple Projects 

Contents 

• Managing Multiple Projects 

• Sharing Resources Among Projects 

Managing Multiple Projects 

In Microsoft Project, you can take advantage of opportunities for consolidation 

projects, to distribute them in smaller pieces, then combine them to obtain a full 

view of the whole project. If we are faced with a problem that is usually easier to 

find the solution if we can simplify it. The same applies to the management of 

complex project - it is easier to work simultaneously on a limited number of tasks. 

Microsoft Project simplifies planning of large and complex projects. Using the 

properties of the consolidation program, you can create sub-projects, which will 

be treated as the task of forming a single large project. When you create a sub-

project, we must save it as a separate project file. We can allocate resources, 

create links and constraints, as if it were a complete design. When we look at the 

whole, we combine subprojects into one big project. During the consolidation of a 

project put inside the other, so called sub-projects are also inserted. You create a 

new Project file and then insert separate Project files into that one consolidated 

file. A master project is great for assembling multiple subprojects into one place, 

but it works equally well if you’re just dealing with a bunch of unrelated projects. 

Although you can insert a Project file into any other Project file, the most common 

approach is to create a master project - a Project file that contains other projects 

inserted into it. 

The characteristics of the master project 

All the inserted subprojects assemble cheerfully in one Project window, so you 

can work on and save them all as if they were a single file. 

• The inserted projects look like summary tasks, which you can expand to 

show all the subtasks, or collapse to see the big picture. 
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• You can work on subproject tasks as if they belong to the master project- 

modifying, sorting, filtering, and grouping the aggregated tasks. 

• Because a master project is a regular Project file, you can add tasks to it – 

for example, for the work you do supervising the other project managers. 

Creating a Master Project 

1. Choose File → New, and then, in the Available Templates screen, double-

click Blank project.  

2. Select the first blank row and choose Project → Insert → Subproject. 

3. Select the project you want to insert, make sure the Link to project 

checkbox is turned on, and then click Insert. 

4. Repeat steps 2–3 to insert additional projects. 

When you insert a project, placing it directly over the selected row. Therefore, if 

the project contains tasks inserted in the Task Name column, click the task that is 

to be placed directly under our subproject. 

Work on the inserted projects as you would regular tasks. 

1. Choose Task → Schedule → Indent Task or Outdent Task to move the 

inserted project to the correct level of the task hierarchy. 

2. Right-click the Gantt Chart table heading area, and then choose Insert 

Column. In the drop-down list, choose Subproject File.  

If you need help identifying tasks and resources from different subprojects, 

you can insert the Subproject File column into your Gantt Chart table. 

Removing a Project from a Master Project 

1. In the Gantt Chart view, select the ID cell for the inserted project 

summary task. Press Delete. 

2. Alternatively you can right-click the task and choose Delete Task on the 

shortcut menu. Make sure the Continue option is selected, and then click 

OK. 
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Linking Tasks in Different Projects 

Maybe only a few tasks in one project link to tasks in another project. The easiest 

way to link tasks in different projects is to open both projects and then create an 

external task dependency. 

How to create an external task dependency: 

1. In Project, open the projects that contain the predecessor task and the 

successor task. 

2. To view both projects at the same time so you can see the tasks you want 

to link, choose View → Window → Arrange All. 

3. Select the task that’s the successor in this external task dependency. To 

open the Task Information dialog box, press Shift+F2 (or choose Task → 

Properties → Information), and then select the Predecessors tab. 

4. Click the first blank ID cell, and then type the name of the project that 

contains the predecessor task, followed by a backslash and the task ID. 

5. Press Enter to save the external task dependency and click OK. 

6. To change the type of task dependency or to set lead or lag time, select 

the successor task once more, and then press Shift+F2. 

Sharing Resources Among Projects 

If you use the same resources when working on multiple projects should create a 

pool of resources. This is a set of resources available for each project. The 

resources can be used when working on a project or they can be shared by several 

projects. 

Creating a resource pool in the program may facilitate their administration, 

particularly in the case of shared resources for several projects. In order to create 

a resource pool is sufficient to create a project file containing only resource 

information. 

How to create a standalone resource pool: 

1. Choose File → New. Under Available Templates, double-click Blank 

project. 
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2. Choose View → Resource Views → Resource Sheet. Fill in information 

about your shared resources. Typically, you fill in resource names, their 

standard charge rates or cost, and the maximum availability for work 

resources. 

3. Choose File → Save, and then name the project something meaningful 

(like Resource Pool). 

Connecting a Project to a Resource Pool 

Before you can assign resources from a resource pool to project tasks, you must 

link the file to the resource pool. Any Project file that uses a resource pool is 

known as a sharer file. 

How to connect a project to the resource pool: 

1. In Project, open the resource pool and open the Project file that you want 

to access the resource pool. 

2. With the Project file active, choose Resource → Assignments → Resource 

→ Pool → Share Resources. Select the Use resources option and then, in 

the From drop-down list, choose the resource pool. 

3. Under On conflict with calendar or resource information, select an option 

to tell Project how you want to resolve resource information 

discrepancies and click OK. 

4. The best choice is to let the resource pool take precedence (select Pool 

takes precedence), because the resource pool then has the final say about 

resource information. 

Detaching a Sharer Project from the Resource Pool 

You can disconnect a sharer file from the resource pool, which is perfect if your 

project gets canned before it gets started. 

How to remove a project from the resource pool: 

1. Choose Resource → Assignments → Resource Pool → Share Resources. 

2. Select the “Use own resources” option, and then click OK. 
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Exercise. 

1. Create two projects. Assign tasks, resources and costs. 

2. Crate master project and sub project. 

3. Create the sharing resources among projects. 
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Module 8. Own Project 

To summarize your knowledge and experience on Microsoft Project Professional 

as a tool supporting your daily work in a role of project manager create your own 

project plan. 

The subject of the project is a matter of agreement between you and your 

supervisor. The list bellow consists of a proposition only which you shall treat as 

the suggestions or inspiration. Try to find your own interesting subject for your 

project you will develop. 

Propositions of the projects 

Designing and implementation integrated computer system for production 

company that is going to automate its resource enterprise planning. You are a 

project leader managing with your team of consultants and software architects. 

Some external support is necessary as your team lacks of expertise in some 

domains. The system architecture shall be results of set of audits and 

consultancies in the several locations of the company. The software will be 

created from scratches. Do not forget to extend testing and implementation 

phase. 

Elements of the project 

Project plan should be prepared as Microsoft Project file. It should consist of all of 

the elements presented in sections 1 to 7. 

1. Detailed plan of the project should consist of:  

a. at least 5 main phases, 

b. tasks definition for each phase. 

2. Project should be scheduled automatically on the basis of: 

a. relations between tasks, 

b. constraints applied on the selected tasks. 

3. Resources pool should consists of 
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a. set of generic resources and named resources, 

b. material-type resources, 

c. cost definition of all kind. 

4. Detailed report on the budget of the project presenting different aspects 

of cost analysis. 

5. Prepare what if analysis containing at least one alternative scenario of the 

project realization together with resulting budget.  

6. Simulate reactions on serious problems that affect the realization of the 

project.  

a. present reports on the project realization, 

b. compare current status of the project with base plan, 

c. apply some amendments to the project, 

d. present resulting deviation from base plan. 

Project documentation 

The project documentation should be prepared according to rule presented 

during the course lectures. 

Recommendation 

It is recommended to propose the project title at the beginning of the course and 

work out elements of the required documentation sequentially immediately after 

each classes.  

Create two projects. Assign each task, resources and costs. 

Create master project and sub project. 

Create the sharing resources among projects. 
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